Как выяснилось, новый стандарт имеет для ОС свои ограничения, так например использование библиотеки параллельных вычислений Concurrency Runtime требует версии ОС не ниже Windows XP SP3.
Узнать о версии ОС у пользователя можно с помощью функции Concurrency::GetOSVersion
В случае если версия ОС не подходит, будет сгенерирован эксешн unsupported_os. Подробнее на MSDN.

Лимит версии ОС для C++0x Concurrency
Метки:            

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *